synopsys arc architecture · Supported
Maintainers
- M Vineet Gupta <vgupta@kernel.org>
Paths
- F
Documentation/arch/arc - F
Documentation/devicetree/bindings/arc/* - F
Documentation/devicetree/bindings/interrupt-controller/snps,arc* - F
arch/arc/ - F
drivers/clocksource/arc_timer.c - F
drivers/tty/serial/arc_uart.c
Last 30 days
Recent patches
Most-recent 19 patches in this subsystem on linux-block, ordered by date desc.
-
COLD29d
[PATCH 03/19] arc: define DPS root partition type UUID
2026-06-15 · Vincent Mailhol <mailhol@kernel.org> -
STALE280d
[PATCH RESEND 56/62] init: rename CONFIG_RD_GZIP to CONFIG_INITRAMFS_DECOMPRESS_GZIP
2025-09-14 · Askar Safin <hidden> -
STALE280d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE280d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE280d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE280d
[PATCH RESEND 25/62] init: rename phys_initrd_{start,size} to phys_external_initramfs_{start,size}
2025-09-13 · Askar Safin <hidden> -
STALE302d
LANDED [PATCH v2 3/4] arch: copy_thread: pass clone_flags as u64
2025-09-01 · Simon Schuster via B4 Relay <devnull+schuster.simon.siemens-energy.com@kernel.org> -
STALE1673d
Re: [PATCH v2 01/28] csky,sparc: Declare flush_dcache_folio()
2021-11-16 · Matthew Wilcox <willy@infradead.org> -
STALE1673d
Re: [PATCH v2 01/28] csky,sparc: Declare flush_dcache_folio()
2021-11-16 · Christoph Hellwig <hch@infradead.org> -
STALE2060d
[PATCH 1/2] genirq: add an affinity parameter to irq_create_mapping()
2020-11-24 · Laurent Vivier <hidden> -
STALE2657d
[PATCH] block: remove CONFIG_LBDAF
2019-04-05 · Christoph Hellwig <hch@lst.de> -
STALE3004d
[PATCH 5/5] PCI: remove PCI_DMA_BUS_IS_PHYS
2018-04-24 · Christoph Hellwig <hch@lst.de> -
STALE3006d
[PATCH 08/12] arch: define the ARCH_DMA_ADDR_T_64BIT config symbol in lib/Kconfig
2018-04-23 · Christoph Hellwig <hch@lst.de> -
STALE3006d
[PATCH 07/12] arch: remove the ARCH_PHYS_ADDR_T_64BIT config symbol
2018-04-23 · Christoph Hellwig <hch@lst.de> -
STALE3014d
[PATCH 12/12] PCI: remove PCI_DMA_BUS_IS_PHYS
2018-04-16 · Christoph Hellwig <hch@lst.de> -
STALE3009d
[PATCH 08/12] arch: define the ARCH_DMA_ADDR_T_64BIT config symbol in lib/Kconfig
2018-04-15 · Christoph Hellwig <hch@lst.de> -
STALE3009d
[PATCH 07/12] arch: remove the ARCH_PHYS_ADDR_T_64BIT config symbol
2018-04-15 · Christoph Hellwig <hch@lst.de> -
STALE3065d
[PATCH] fix double ;;s in code
2018-02-17 · Pavel Machek <hidden> -
DORMANTno replies
[PATCH 3/3] dma-mapping: replace PCI_DMA_BUS_IS_PHYS with a flag in struct dma_map_ops
2017-12-04 · Christoph Hellwig <hch@lst.de>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
COLD29d
[PATCH 03/19] arc: define DPS root partition type UUID
2026-06-15 · Vincent Mailhol <mailhol@kernel.org>